読者です 読者をやめる 読者になる 読者になる

のらぬこの日常を描く

ノージャンルのお役立ち情報やアニメとゲームの話、ソフトウェア開発に関する話などを中心としたブログです。

RMagick のインストールでちょっとハマる

ubuntu にRMagick をインストールしたければ

$ sudo aptitude update
$ sudo aptitude install libmagick9-dev ruby1.8-dev
$ sudo gem install rmagick

で、インストール完了。。。のはずなのだが

irb>require 'rubygems'
=>true
irb>require 'RMagick'
=> This installation of RMagick was configured with ImageMagick 6.5.5 but ImageMagick 6.5.7-8 is in use.

のようなエラーが・・・・


原因は、apt-getで、事前に別バージョンの rmagick-ruby をインストールしてしまったことにあったようです*1

$ sudo apt-get remove --purge librmagick-ruby-doc librmagick-ruby1.8

した後、再度

$ sudo gem install rmagick

で、うまく行った。

*1:Webで調べてそれっぽいページからそれっぽいコマンドを適当にコピペすると、後でハマるという例